Microtech Area is for discussing Microtech systems

Microtech Microtech cable socket dead?

Old 06-17-08, 03:08 AM
  #1  
Rotary Enthusiast
Thread Starter
iTrader: (6)
 
Join Date: Mar 2006
Location: The Evergreen State (WA)
Posts: 823
Likes: 0
Received 0 Likes on 0 Posts
Microtech cable socket dead?

Alright so I was curious if there is a way to fix the microtech socket. I think mine might be messed up. I bought a hand controller it lights up but nothing on the screen. I sent it back to viperkiller and he says it works fine. I don't know why it won't work on mine... I don't think it is the cable cuz I directly connected it without the cable and it did the same thing... I need to figure this out cuz my car is on hold again due to college tuition. So I got some time...
asiandude15 is offline  
Old 06-17-08, 03:38 AM
  #2  
Rotary Freak
iTrader: (8)
 
rx72c's Avatar
 
Join Date: Jun 2003
Location: Australia
Posts: 2,608
Likes: 0
Received 0 Likes on 0 Posts
only way would be to pull the computer apart and see if any of the solder joints have broken.
rx72c is offline  
Old 06-17-08, 07:20 PM
  #3  
Rotary Enthusiast
Thread Starter
iTrader: (6)
 
Join Date: Mar 2006
Location: The Evergreen State (WA)
Posts: 823
Likes: 0
Received 0 Likes on 0 Posts
Dammit any idea how much microtech would charge to fix it?
asiandude15 is offline  
Old 06-18-08, 02:40 PM
  #4  
Rotary Enthusiast
10 Year Member
iTrader: (1)
 
mort2002's Avatar
 
Join Date: Jul 2003
Location: Prosser Washington
Posts: 1,248
Likes: 0
Received 0 Likes on 0 Posts
hey i have my lap top and dongle now, if you wanna try it, i might be making a trip to tri cites this weekend, and i could bring it....
mort2002 is offline  
Old 06-29-08, 01:01 PM
  #5  
1.3 liters of whoop ass
iTrader: (11)
 
viperkiller7's Avatar
 
Join Date: Mar 2002
Location: Reading pa
Posts: 1,174
Likes: 0
Received 0 Likes on 0 Posts
2 thng i found out asiandude....i took the screws off the mcrotech to attach the handset directly to it..nothing happened..so i plugged the line in with the controller with the 2 screws still off the microtech again nothing. so i put the 2 screws back in hooked the cable and controller up and it worked.. hope this helps
viperkiller7 is offline  
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
TeamRuffRacing
Adaptronic Engine Mgmt - AUS
1
09-30-15 08:13 PM


Thread Tools
Search this Thread
Quick Reply: Microtech Microtech cable socket dead?


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
 
  • Ask a Question
    Get answers from community experts
Question Title:
Description:
Your question will be posted in: