Microtech Area is for discussing Microtech systems

LT-9c Laptop Connection Issues

Old 12-11-18, 11:59 AM
  #1  
Junior Member
Thread Starter
 
Join Date: Aug 2017
Location: On the internet, confused
Posts: 20
Likes: 0
Liked 0 Times in 0 Posts
LT-9c Laptop Connection Issues

I am stumped on this one. Last year I was able to connect my laptop (windows 10) to the ECU and tune it, datalog, etc. Everything worked properly connecting through the Microtech serial dongle and a Sabrent serial to USB converter. However, I go to make some more tuning and setting changes, and suddenly the same setup does not work anymore. I reinstalled Microtech software and drivers and the USB-serial driver to no avail. Com port settings are correct. I know the serial-USB converters are hit or miss, so I dug out a laptop old enough it has a serial port. After installing the drivers and software, I encountered exactly the same issue.

The laptop software recognizes a device (because I don't get a "Com port not available" error), but it simply fails to connect. This issue is the same using the USB to serial converter or connecting straight through serial, and on a different computer.

What else changed since last time I was able to connect? The car was re-wired (fixing mystery fuses and adding needed relays). However, all the signs I have show the ecu is wired correctly and performing as expected. The engine starts and runs, and all of the auxiliary functions work. Is there anything wiring related that would might affect only the connection?

Beyond that, the only thing left is the stupid Microtech serial dongle. Does anyone know a way to check if that is good?
GabeSeveryn is offline  
Old 01-07-19, 05:20 AM
  #2  
Can Post Only in New Member Section
 
Join Date: Aug 2010
Location: sydney
Posts: 4
Likes: 0
Liked 0 Times in 0 Posts
Cable

The usb cable needs to be
replaced
stewart7 is offline  
Old 01-07-19, 03:27 PM
  #3  
Junior Member
Thread Starter
 
Join Date: Aug 2017
Location: On the internet, confused
Posts: 20
Likes: 0
Liked 0 Times in 0 Posts
Originally Posted by stewart7 View Post
The usb cable needs to be replaced
Thanks for your response! The usb cable was my first thought too. Using a laptop with a native serial port removed the USB cable from the system, but gave me exactly the same behavior. I have also tried a completely different USB-serial adapter and still got the same results.

I reached out here to see if anyone has an uncommon solution or knows of a complexity I don't know about. I'm flat out of ideas, when I'd rather be flat out in my rotary.
GabeSeveryn is offline  
Old 04-14-19, 12:56 PM
  #4  
japan connection
iTrader: (52)
 
Circuit Theory's Avatar
 
Join Date: Nov 2004
Location: Japan & California
Posts: 2,066
Likes: 0
Liked 0 Times in 0 Posts
I am having a similar issue. Mine 9C recognizes the laptop and flashes to the connected screen briefly then disconnects itself.
I have only tried one cable and may buy another and see if it works but not sure it will.
While messing with it all I updated the driver and it did not make a difference.
Circuit Theory is offline  
Old 04-15-19, 10:06 AM
  #5  
Junior Member
Thread Starter
 
Join Date: Aug 2017
Location: On the internet, confused
Posts: 20
Likes: 0
Liked 0 Times in 0 Posts
To bring some closure to this thread, my issue was not with the computer or cable or adapter at all. I had some very smart electrical friends come over and diagnose my setup. The cables and adapter worked as expected, so he opened up the ECU. The chip/board responsible for serial communication had fried. This was the only piece that was toasted, which explained why the ECU functioned normally, just without communication ability.

Chances are the part died from environmental causes, because my ECU is mounted in the engine bay. A replacement ECU was the best fix for my situation, and now I can connect and program it as intended.

Circuit Theory - I can't say if your problem is the same as mine, but I hope it's not,because that was an expensive fix.
GabeSeveryn is offline  
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
thelevman
Haltech Forum
5
08-20-10 05:49 PM


Thread Tools
Search this Thread
Quick Reply: LT-9c Laptop Connection Issues


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
 
  • Ask a Question
    Get answers from community experts
Question Title:
Description:
Your question will be posted in: