Microtech Area is for discussing Microtech systems

Microtech idle issues

Old 06-25-07, 01:13 PM
  #1  
Scream baby Scream!!!
10 Year Member
Thread Starter
 
Rotorhead34's Avatar
 
Join Date: Sep 2002
Location: Clarksville, Tn.
Posts: 434
Likes: 0
Received 0 Likes on 0 Posts
idle issues

Okay, I have the car running, but not well. I have 750cc primary, 1000cc secondary, T04E ar60-1/ .98 on the hot side. Microtech LT10s, x4 and the hand controller. All is hooked up and seems to be reading all the values, although, they are still in need of adjustment. I'm having trouble getting the car to idle. The lowest I got it to idle was 1250rpms. Anything lower than that, it will bog until it dies. I haven't been able to set the timing yet because of the idle. I'm not in full understanding of the what the values mean on the screen of the hand controller. the 30hg; whats the hg mean and the 1.43;?

Also, I read in hear somewhere about moving the cas one tooth to set the timing? I did notice last night the hand controller was reading my timing and it would flucuate between 15BTDC and 20BTDC depending on the rpms of course at idle. I didn't pay much attention to it yet as I haven't got far enough to lock the timing to set it. Just wanted to know if this is still the practice of setting the timing.

I did notice that the afr was around 11. Is this right? I thought it was better closer to 14.

I'm just trying to get it good enough to go to the dyno. Thanks
Rotorhead34 is offline  
Old 07-04-07, 12:02 AM
  #2  
Rotary Freak
iTrader: (8)
 
rx72c's Avatar
 
Join Date: Jun 2003
Location: Australia
Posts: 2,608
Likes: 0
Received 0 Likes on 0 Posts
sounds like your tps is out.
when no throttle is being applied tps needs to be on 0.

idle afr to get it smooth will be around the 12 mark.

and idle timing should be between 0 and 5 degrees on anything but a bridgeport or PP.
rx72c is offline  
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
rgordon1979
3rd Generation Specific (1993-2002)
39
12-27-17 10:09 AM
barkz
Power FC Forum
36
06-17-16 03:49 AM
troym55
3rd Generation Specific (1993-2002)
23
05-25-16 12:42 PM
83revival
New Member RX-7 Technical
4
09-03-15 10:42 PM


Thread Tools
Search this Thread
Quick Reply: Microtech idle issues


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
 
  • Ask a Question
    Get answers from community experts
Question Title:
Description:
Your question will be posted in: