Go Back  RX7Club.com - Mazda RX7 Forum > Tech and Performance > Engine Management Forum > Microtech
Reload this Page >

Car takes a bit to crank but when it does i have a blinking red light

Microtech Area is for discussing Microtech systems

Car takes a bit to crank but when it does i have a blinking red light

Old 04-08-15, 05:08 PM
  #1  
Full Member
Thread Starter
 
turbofc7's Avatar
 
Join Date: Nov 2014
Location: florida
Posts: 64
Likes: 0
Received 0 Likes on 0 Posts
Car takes a bit to crank but when it does i have a blinking red light

K so I have a cosmo 13bre in my fc and Iv noticed that it takes a minute to crank on when I turn the ignition on i get a green and yellow light and then I go to crank and when I do it will almost crank and stall 2-3 times then it'll crank up n run nice but when it's running I notice that my lt10s the green and yellow are on and then every 3-4 the red light will come in for like 2 seconds or if I hit the throttle it will come on too but the car seems to run ok.... I dunno Im new to the whole fuel injection ecu stand alone thing but I think something might be up an u gurus shed some light on this?
turbofc7 is offline  
Old 04-08-15, 07:26 PM
  #2  
Full Member
Thread Starter
 
turbofc7's Avatar
 
Join Date: Nov 2014
Location: florida
Posts: 64
Likes: 0
Received 0 Likes on 0 Posts
Anyone?
turbofc7 is offline  
Old 04-09-15, 01:25 PM
  #3  
Full Member
Thread Starter
 
turbofc7's Avatar
 
Join Date: Nov 2014
Location: florida
Posts: 64
Likes: 0
Received 0 Likes on 0 Posts
????
turbofc7 is offline  
Old 04-10-15, 06:22 PM
  #4  
Senior Member
 
Join Date: Nov 2006
Location: connecticut
Posts: 362
Likes: 0
Received 0 Likes on 0 Posts
if the red light blink you have a error check that first.
elturbonitroso is offline  
Old 06-11-15, 11:17 PM
  #5  
Full Member
10 Year Member
 
hickman's Avatar
 
Join Date: Apr 2004
Location: Nanaimo, B.C. Canada
Posts: 69
Likes: 0
Received 0 Likes on 0 Posts
Check your battery, if it is low and dips below (I think its 8v) it will set and error code for a red light for 'low voltage'
hickman is offline  
Old 06-20-15, 10:13 AM
  #6  
Engine, Not Motor
iTrader: (1)
 
Aaron Cake's Avatar
 
Join Date: Feb 2001
Location: London, Ontario, Canada
Posts: 29,671
Likes: 0
Received 23 Likes on 22 Posts
The ECU will show the source of the error on the laptop and/or handheld.

But battery voltage is good start.
Aaron Cake is offline  
Old 06-26-15, 11:49 AM
  #7  
Old Rotary Dude
iTrader: (33)
 
jtbshaw's Avatar
 
Join Date: Jun 2003
Location: Jemison, AL
Posts: 487
Likes: 0
Received 0 Likes on 0 Posts
My LT8s will flash the error if the voltage is less than 10V.

Just as Aaron stated, see what the ECU shows n a laptop or handheld. It shouldn't be anything major.
jtbshaw is offline  
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
trickster
2nd Generation Specific (1986-1992)
20
03-29-18 02:05 PM
Leeroy_25
3rd Generation Specific (1993-2002)
4
08-17-15 12:53 PM


Thread Tools
Search this Thread
Quick Reply: Car takes a bit to crank but when it does i have a blinking red light


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
 
  • Ask a Question
    Get answers from community experts
Question Title:
Description:
Your question will be posted in: