Microtech Area is for discussing Microtech systems

Microtech break up issues

Old 10-12-10, 01:21 PM
  #1  
^^rotard for life^^
10 Year Member
Thread Starter
iTrader: (3)
 
rob81gsl's Avatar
 
Join Date: Sep 2004
Location: Orlando
Posts: 906
Likes: 0
Received 0 Likes on 0 Posts
break up issues

I recently tried to make the e85 swap along with running 4 1600cc injectors. immediately ran into issues with ignition break up.

little back ground info here. using lt10s with the x4 box and bosch coils. on a s5 sp engine with 6765 turbo and makes 500hp at 20lbs of boost on regular 93.

the fuel maps were tuned in and the break up wouldnt go away. i also tried changing timing maps and nothing worked. so i've come to the conclusion that the igniton is not strong enough to burn all that fuel. has anyone else using this standard setup ran into this issue?
rob81gsl is offline  
Old 10-13-10, 12:41 AM
  #2  
Rotary Freak
iTrader: (8)
 
rx72c's Avatar
 
Join Date: Jun 2003
Location: Australia
Posts: 2,608
Likes: 0
Received 0 Likes on 0 Posts
What afrs are you running?
rx72c is offline  
Old 10-13-10, 06:34 AM
  #3  
Full Member
5 Year Member
 
Join Date: Nov 2006
Location: Suffolk, VA
Posts: 209
Likes: 0
Received 0 Likes on 0 Posts
Originally Posted by rob81gsl View Post
I recently tried to make the e85 swap along with running 4 1600cc injectors. immediately ran into issues with ignition break up.

little back ground info here. using lt10s with the x4 box and bosch coils. on a s5 sp engine with 6765 turbo and makes 500hp at 20lbs of boost on regular 93.

the fuel maps were tuned in and the break up wouldnt go away. i also tried changing timing maps and nothing worked. so i've come to the conclusion that the igniton is not strong enough to burn all that fuel. has anyone else using this standard setup ran into this issue?
Yes i did had the same problem running 100% methanol. I had to upgrade to MSD DIS4 boxes.
bori113 is offline  
Old 10-13-10, 11:29 AM
  #4  
^^rotard for life^^
10 Year Member
Thread Starter
iTrader: (3)
 
rob81gsl's Avatar
 
Join Date: Sep 2004
Location: Orlando
Posts: 906
Likes: 0
Received 0 Likes on 0 Posts
was trying to tune for 11.5 tried taking it up to 12 and it was making pulls but they still werent clean
rob81gsl is offline  
Old 10-14-10, 02:13 AM
  #5  
Rotary Freak
iTrader: (8)
 
rx72c's Avatar
 
Join Date: Jun 2003
Location: Australia
Posts: 2,608
Likes: 0
Received 0 Likes on 0 Posts
Lift up the Dwell to 4.5 ms.

And bring afrs up to 12.4

If it dosnt clear up. Get stronger ignition.
rx72c is offline  
Old 10-15-10, 07:52 AM
  #6  
^^rotard for life^^
10 Year Member
Thread Starter
iTrader: (3)
 
rob81gsl's Avatar
 
Join Date: Sep 2004
Location: Orlando
Posts: 906
Likes: 0
Received 0 Likes on 0 Posts
you can really take the afrs up that high and not detonate on the e85???
rob81gsl is offline  
Old 10-15-10, 09:54 PM
  #7  
Rotary Freak
iTrader: (8)
 
rx72c's Avatar
 
Join Date: Jun 2003
Location: Australia
Posts: 2,608
Likes: 0
Received 0 Likes on 0 Posts
of course especially on only 20psi.

You dont really run much richer then that even on 30psi.
rx72c is offline  
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
Jeff20B
1st Generation Specific (1979-1985)
73
09-16-18 07:16 PM
rgordon1979
3rd Generation Specific (1993-2002)
39
12-27-17 10:09 AM
blackball7
2nd Generation Specific (1986-1992)
34
09-16-15 10:10 AM
Frox
General Rotary Tech Support
2
09-08-15 08:36 AM
Steven_McKinley
General Rotary Tech Support
12
09-05-15 10:48 AM


Thread Tools
Search this Thread
Quick Reply: Microtech break up issues


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
 
  • Ask a Question
    Get answers from community experts
Question Title:
Description:
Your question will be posted in: