RX7Club.com


Go Back   RX7Club.com > Generation Specific > 2nd Generation Specific (1986-1992)
Register Forgot Password?

Welcome to RX7Club.com!
Welcome to RX7Club.com,

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, at no cost, you will have access to start new topics, reply to conversations, privately message other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join RX7Club.com today!


Reply
 
 
 
 
LinkBack Thread Tools Search this Thread Display Modes
Old 12-06-11, 09:36 PM   #1
Insane Burnout
 
Trader Score: (2)

Join Date: Aug 2011
Location: Miami, FL
Posts: 254
Unhappy excessive oil consumption and cold start cloud of smoke

like the title reads i am having this oil issue with my 7. Some mornings i start it up and it revs to 3000 rpm as it should = no smoke or smell of oil. Other mornings it starts up, go straight to idling and theres is a BIG cloud of smoke for about 2 to 4 minutes. During the day it doesnt smoke one single bit. no smoke at all. I dont know what is going on. I bought a new thermal plug because of what i read in the atkins website
"When the factory thermal pellet starts going out the thing clients comment on the most is excessive oil smoke at start up, which tends to go away as the car warms up and the catalytic conerter cleans up the exhaust"

Im planning on replacing it this weekend. My first thought was that the oil rings were bad but it doesnt smoke all the time and for like 2 or 3 days it doesnt smoke.

My second problem is that is consuming a lot of oil. I did an oil change about 4 weeks ago and yesterday the oil pan was empty. i went to check because it turned the oil light on and the stick was clean. i checked again and clean again.

I went to the auto parts and re fill it.

I cant figure this out. and it doesnt leak oil from anywhere
airman90 is offline   Reply With Quote
Old 12-06-11, 09:37 PM   #2
Insane Burnout
 
Trader Score: (2)

Join Date: Aug 2011
Location: Miami, FL
Posts: 254
I will post video tomorrow after work
airman90 is offline   Reply With Quote
Old 12-06-11, 10:24 PM   #3
They live We sleep
 
rx7_FREAKKK's Avatar
 
Trader Score: (1)

Join Date: Feb 2009
Location: Dot Island
Posts: 925
Quote:
Originally Posted by airman90 View Post
I will post video tomorrow after work
thats why i had to rebuild mine. it started by smoking in the mornings.. and other mornings it didnt. I think this could be due to where the engine stops when you shut it down. When the part of the oil control ring fails and the engine stops at the location where the oil can drip down into the engine and exhaust after engine is shut down it will then be there to burn off after the engine is started,. But this is a my opinion. I just did a rebuild all is fine now. Fix the oil control rings.. it will only get worse. and you will spend lots of money keeping oil in it.. Dont make the mistake i did. and just drive it and spend money to keep oil in it. It will cost you an arm and a leg, But make sure it is the oil control orings. and not something else.. the metel rings should be reusable. its the Orings that get hard and brittle if the oil stays to hot
rx7_FREAKKK is offline   Reply With Quote
Old 12-07-11, 04:54 PM   #4
Insane Burnout
 
Trader Score: (2)

Join Date: Aug 2011
Location: Miami, FL
Posts: 254
i was trying to avoid doing that but oh well. One question how long did it take you to rebuild it? this one is my daily so i dont have much time
airman90 is offline   Reply With Quote
Old 12-07-11, 05:11 PM   #5
Trunk Ornament
5 Year Member
 
AGreen's Avatar
 
Trader Score: (11)

Join Date: Sep 2006
Location: Goose Creek, SC
Posts: 3,007
I thought you've already asked this question before...





Quote:
Originally Posted by Karack
you probably got a rebuilt engine with worn out components, ie someone reused irons that have well beyond spec for iron and oil seal tract step wear on the irons.
__________________
Listing your modifications in your signature line is like having a tramp stamp. It's not clever, but you can't help but look at it.
AGreen is offline   Reply With Quote
Old 12-07-11, 08:14 PM   #6
Insane Burnout
 
Trader Score: (2)

Join Date: Aug 2011
Location: Miami, FL
Posts: 254
yea similar question. i was not sure about the problem but i guess im going to rebuild it and thats it. this is going to be my first rebuild so i dont exactly what parts i need any help will be appreciated
airman90 is offline   Reply With Quote
Old 12-07-11, 08:14 PM
RX7Club
Mazda RX7




Paid Advertisement


 
 
 
Reply

Tags
cloud, excessive, rx7club, smoke, startup

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On


All times are GMT -5. The time now is 10:10 PM.
All content Copyright 2007 by Internet Brands, Inc.

Contacts