Single Turbo Lean @ High RPM - RX7Club.com



Single Turbo Lean @ High RPM

Reply
 
 
Old 03-20-17, 05:09 PM
  #1
Junior Member
Thread Starter
iTrader: (1)
 
Join Date: Jan 2016
Location: Virginia
Posts: 49
Single Turbo Lean @ High RPM

What's up everyone, I have a 93 RX7, Large Streetport 13b, Single T76 GReddy kit, 550cc Primary, 1600cc Secondary, Walboro 255LPH and an Aeromotive FPR. Car is on wastegate boost of 12-ish psi. The car runs pretty good, but it has a few odd spots. For instance, at a WOT pull and high RPM, the car has an A/R of 14 or so, and if I cruise at 70mph and keep my foot in 1 spot, the car starts to lean out around 15 - 16 AFR and you can feel the car slow down like im barely on the brakes... Here is a DropBox link to the tune and logs if someone would be so kind as to help me diagnose this issue

https://www.dropbox.com/sh/228igpa4b...oIpffn5va?dl=0
cstone94 is offline  
Reply With Quote
Old 03-22-17, 02:10 PM
  #2
rotorhead
iTrader: (3)
 
arghx's Avatar
 
Join Date: Aug 2004
Location: cold
Posts: 14,979
did you rewire the fuel pump?
arghx is offline  
Reply With Quote
Old 03-23-17, 12:27 PM
  #3
Gang Of Fatty
15 Year Member
iTrader: (2)
 
cewrx7r1's Avatar
 
Join Date: Feb 2001
Location: In A Blue Police Box
Posts: 7,442
What duty cycle is recorded for high rpms?
Maybe you are running out of pump, or the pump is wearing out, or flow reduction due to a restriction.

Idle should be lean for best mileage.
cewrx7r1 is offline  
Reply With Quote
 
 
Reply


Thread Tools
Search this Thread

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -5. The time now is 03:34 PM.


All content Copyright 2007 by Internet Brands, Inc.