RX7Club.com


Go Back   RX7Club.com > Tech and Performance > Engine Management Forum > Power FC Forum
Register Forgot Password?
Register Photos FAQ Members Search Today's Posts Mark Forums Read Vendor DirectoryUsed Cars Garage
Welcome to RX7Club.com

Reply
 
 
 
 
LinkBack Thread Tools Search this Thread Display Modes
Old 04-17-06, 12:36 AM   #1
Eats, Sleeps, Dreams Rotary
10 Year Member
 
87GTR's Avatar
 
Trader Score: (61)

Join Date: Aug 2001
Location: Nago Okinawa
Posts: 3,103
Installed AP Engineering Power FC for FC3S

Over the weekend I installed the Apexi Power FC for FC3S in my Infini. The install was mostly painless. I removed the AFM, stock boost sensor and stock air temp sensor. I used the Apexi 3 bar map sensor, FD3S air temp sensor.

At first I got some crazy idea to put the air temp under the upper intake manifold (just like on the FD’s). I totally forgot what it was like to take off a stock upper and tb. Once I got it out I raise it above my head like “the predator” pulling that guys spine out. Well after I got out I decided not to put under it, and ended up putting it in the same location the FC air temp sensor was in the TB elbow. retaped the hole and installed it.

The car started right up 1st time. Hopefully will be able to get it tuned soon. The car drives better and feels better on the butt dyno.


only thing I noticed is I still have the therowax and when I start up the car cold it goes to 2k and stay there until it reaches normal temp. after that it starts and drops right to 750rpm.

While I was doing the install I also removed the HKS EVC and found the hose that goes to the accuator was crimp so bad that I dont see how the boost controller worked.

any know where to get speed singnal at? thats the only thing I didnt connect. If I remember right its a white wire that in cpu box in the kick pannel.


here is some picks

Click the image to open in full size.

before removing the boost sensor/ knight sports fcd / afm
Click the image to open in full size.

mounted the apexi 3 bar map sensor on the firewall.
Click the image to open in full size.

old ecu
Click the image to open in full size.

Apexi Power FC and Harness
Click the image to open in full size.

The only give you double sided tape to mount the ecu. Im going to build some brackets this weekend and mount it more solid.
__________________
R.I.P. 90 FC3S Infini Ver 4
92 JC Comso
Okinawa Photoblog
perl -le '$_="6110>374086;2064208213:90<307;55";tr[0->][ LEOR\!AUBGNSTY];print'
Amateur Astronomy Picture of the Day
87GTR is offline   Reply With Quote
Old 04-17-06, 01:00 AM   #2
I R SAD PANDA W/O BAW
10 Year Member
 
ilike2eatricers's Avatar
 
Trader Score: (0)

Join Date: Nov 2002
Location: bay area
Posts: 6,061
Cool nice to see someone else running an AP PFC

The speed sensor wire connects with the signal wire from the cruise control. I forget exactly which one because I never bothered since it would only read in km's. I'm using a stock FD map and AIT temp sensor
ilike2eatricers is offline   Reply With Quote
Old 04-17-06, 01:15 AM   #3
HARDCORE chest Thumper!
5 Year Member
 
Adam P's Avatar
 
Trader Score: (17)

Join Date: Mar 2005
Location: Los Angeles
Posts: 701
Send a message via AIM to Adam P
must be nice
Adam P is offline   Reply With Quote
Old 04-17-06, 05:55 AM   #4
20B FC owner
10 Year Member
5 Year Member
 
hIGGI's Avatar
 
Trader Score: (7)

Join Date: Feb 2001
Location: Czech Republic [www.rx7cz.net]
Posts: 4,768
Send a message via ICQ to hIGGI Send a message via AIM to hIGGI Send a message via MSN to hIGGI Send a message via Yahoo to hIGGI Send a message via Skype™ to hIGGI
is your PowerFC new or used? how much had to shell for it with FD air temp sensor and 3 bar map?
__________________
hIGGI
Czech RX-7 Club
higgi@rx7cz.net
hIGGI is offline   Reply With Quote
Old 04-17-06, 05:56 AM   #5
I'm a boost creep...
 
NZConvertible's Avatar
 
Trader Score: (0)

Join Date: Jan 2002
Location: Auckland, New Zealand
Posts: 15,608
Quote:
Originally Posted by 87GTR
any know where to get speed singnal at? thats the only thing I didnt connect. If I remember right its a white wire that in cpu box in the kick pannel.
Nope, it's green/red wire. The speed sensor is in the speedo, and the signal is sent to the power steering, cruise control and AAS modules. IIRC you don't have any of those, but since this is a J-spec car the speed signal is also sent to the ECU for the speed limiter. The Apexi adaptor harness has most likely taken care of this connection for you. You'll just need to replace the screw in the back of the instrument cluster to reactivate the ECU speed signal.
__________________
Jason
'88 Turbo Convertible (Japanese import) click for pics
NZConvertible is offline   Reply With Quote
Old 04-17-06, 08:30 AM   #6
Eats, Sleeps, Dreams Rotary
10 Year Member
 
87GTR's Avatar
 
Trader Score: (61)

Join Date: Aug 2001
Location: Nago Okinawa
Posts: 3,103
Quote:
Originally Posted by hIGGI
is your PowerFC new or used? how much had to shell for it with FD air temp sensor and 3 bar map?

The ecu was used. I ended up getting a new commander and map sensor for it

commander is around 300 new and map sensor and harness is around 180.

The fd air temp I took off a FD parts car.
87GTR is offline   Reply With Quote
Old 04-17-06, 08:44 AM   #7
Eats, Sleeps, Dreams Rotary
10 Year Member
 
87GTR's Avatar
 
Trader Score: (61)

Join Date: Aug 2001
Location: Nago Okinawa
Posts: 3,103
Quote:
Originally Posted by NZConvertible
Nope, it's green/red wire. The speed sensor is in the speedo, and the signal is sent to the power steering, cruise control and AAS modules. IIRC you don't have any of those, but since this is a J-spec car the speed signal is also sent to the ECU for the speed limiter. The Apexi adaptor harness has most likely taken care of this connection for you. You'll just need to replace the screw in the back of the instrument cluster to reactivate the ECU speed signal.

in the apexi connector harness it has one really long wire that for speed. I will try to track it down.

I belive the speed limit signal is sent from cluster once it reaches 180km. it should be a on and off. I will put the screw back in and see.

yeah I do think your right about the wire being green/red long time ago I had a avcr that used speed signal
87GTR is offline   Reply With Quote
Old 04-17-06, 08:52 AM   #8
I'm a boost creep...
 
NZConvertible's Avatar
 
Trader Score: (0)

Join Date: Jan 2002
Location: Auckland, New Zealand
Posts: 15,608
Quote:
Originally Posted by 87GTR
I belive the speed limit signal is sent from cluster once it reaches 180km. it should be a on and off.
Ah, I think you're right about that. Sorry, my bad. So you'll need to go to the back of the instrument cluster. I'm only assuming it will actually have a speed signal, since you don't have any of the modules that normally use it. Maybe check out the locations where the power steering and cruise control modules go in case the unused wiring is there.
NZConvertible is offline   Reply With Quote
Old 04-17-06, 10:11 AM   #9
mhhh
 
limbar85's Avatar
 
Trader Score: (5)

Join Date: Oct 2004
Location: Ohio and Obama, Japan
Posts: 711
Send a message via AIM to limbar85
yea....it would be nice to know because i never got my speed to work either.
limbar85 is offline   Reply With Quote
Old 04-18-06, 09:02 AM   #10
RX-7 Bad Ass
10 Year Member
 
DaleClark's Avatar
 
Trader Score: (42)

Join Date: Jan 2002
Location: Pensacola, FL
Posts: 8,880
Every electronic doodad for the FC I've installed (and I've installed a bunch) tapped into the speed sensor on the cruise control harness. Even if you don't have cruise, that wire should still give a good signal, and it's relatively easy to get to and find - it's in the driver's side kick panel. That's probably why the wire is so long as it has to cross over to the other side of the car.

Definitely worth a try. It's in the documentation for stuff like the HKS Type I turbo timer that need a speed signal.

Dale
__________________
| Dale Clark - RX-7 Bad-Ass
| '94 RX-7 R2 Brillant Black - Building the Perfect FD
| Go faster with stripes!
DaleClark is offline   Reply With Quote
Old 04-18-06, 01:55 PM   #11
I R SAD PANDA W/O BAW
10 Year Member
 
ilike2eatricers's Avatar
 
Trader Score: (0)

Join Date: Nov 2002
Location: bay area
Posts: 6,061
Quote:
Originally Posted by DaleClark
Every electronic doodad for the FC I've installed (and I've installed a bunch) tapped into the speed sensor on the cruise control harness. Even if you don't have cruise, that wire should still give a good signal, and it's relatively easy to get to and find - it's in the driver's side kick panel. That's probably why the wire is so long as it has to cross over to the other side of the car.

Definitely worth a try. It's in the documentation for stuff like the HKS Type I turbo timer that need a speed signal.

Dale
You can also look up the wiring instructions for an Apex AVCR too for reference.
ilike2eatricers is offline   Reply With Quote
Old 04-23-06, 02:18 PM   #12
mhhh
 
limbar85's Avatar
 
Trader Score: (5)

Join Date: Oct 2004
Location: Ohio and Obama, Japan
Posts: 711
Send a message via AIM to limbar85
87gtr....did u get the speed thing figured out? let me know if u did and how
limbar85 is offline   Reply With Quote
Old 04-24-06, 02:47 AM   #13
Eats, Sleeps, Dreams Rotary
10 Year Member
 
87GTR's Avatar
 
Trader Score: (61)

Join Date: Aug 2001
Location: Nago Okinawa
Posts: 3,103
yeah I looked in the apexi pdf, I need to track down my cruse control computer.

on my old car in the states it was in the drivers kick panel. Im guessing its in the same location on my RHD car.

http://www.apexi-usa.com/pdfWiring/8.pdf
page 18 - 19
87GTR is offline   Reply With Quote
Old 04-24-06, 06:17 PM   #14
mhhh
 
limbar85's Avatar
 
Trader Score: (5)

Join Date: Oct 2004
Location: Ohio and Obama, Japan
Posts: 711
Send a message via AIM to limbar85
but either way once u find it....are u sure the long wire off the harness is for that?
limbar85 is offline   Reply With Quote
Old 04-26-06, 07:25 PM   #15
Eats, Sleeps, Dreams Rotary
10 Year Member
 
87GTR's Avatar
 
Trader Score: (61)

Join Date: Aug 2001
Location: Nago Okinawa
Posts: 3,103
everyone I have asked say thats what its for. I will stop by the apexi dealer tomorrow. If the weather clears up (been raining past 3 days) on friday I'm going to look for the cruse control box.
87GTR is offline   Reply With Quote
Old 04-27-06, 09:31 PM   #16
Eats, Sleeps, Dreams Rotary
10 Year Member
 
87GTR's Avatar
 
Trader Score: (61)

Join Date: Aug 2001
Location: Nago Okinawa
Posts: 3,103
ok I got the speed working!!! JDM cars its on the driver side kick panel. Mine does not have the cruise box, but I found a connector that was open and matched the layout in the Apexi PDF. The wire is Green with a Red stripe. Looking at the connector its on the bottom row 3 over starting from the left.

yes the long wire is on the harness is for speed but mine is not near long enough. I had to add about 2 feet to mine.

I will post some pics once I clean it up. right now its in test rig mode.
87GTR is offline   Reply With Quote
Old 04-27-06, 11:30 PM   #17
Eats, Sleeps, Dreams Rotary
10 Year Member
 
87GTR's Avatar
 
Trader Score: (61)

Join Date: Aug 2001
Location: Nago Okinawa
Posts: 3,103
pictures here

after I rerouted the test rig, I didnt need to add two feet of wire. the wire stock wire on the harness was just right lenght. I spliced the wire, then soldered it, then used heet shrink over the slice.

http://infini-fc3s.cyberosity.com/ga...+Speed+Signal/

Gotta love Okinawa. Two seasons here Rain and Hot. today its Rain

Click the image to open in full size.

Click the image to open in full size.
__________________
R.I.P. 90 FC3S Infini Ver 4
92 JC Comso
Okinawa Photoblog
perl -le '$_="6110>374086;2064208213:90<307;55";tr[0->][ LEOR\!AUBGNSTY];print'
Amateur Astronomy Picture of the Day

Last edited by 87GTR; 04-27-06 at 11:35 PM.
87GTR is offline   Reply With Quote
Old 05-30-06, 07:14 PM   #18
R.I.P. Icemark
5 Year Member
 
staticguitar313's Avatar
 
Trader Score: (2)

Join Date: Sep 2004
Location: gilbert, arizona
Posts: 4,229
Send a message via AIM to staticguitar313
OK this is awesome, so you can use the APFC in the S5 TII (in this case infini IV) could i use it in my S5 N/A?? I'm turboing the stock engine and this would probably help alot!
__________________
1993 Touring: Tan to Black interior conversion, AZRR Streetport motor, non-sequential twins, Tuned by UMS. thermostat stuck shut and she blew a coolant seal
BMW 325i E30, daily beater
staticguitar313 is offline   Reply With Quote
Old 05-30-06, 07:54 PM   #19
Eats, Sleeps, Dreams Rotary
10 Year Member
 
87GTR's Avatar
 
Trader Score: (61)

Join Date: Aug 2001
Location: Nago Okinawa
Posts: 3,103
Im not sure about a S5 N/A harness you might have to hack the harness up to connect it. I saw somewhere had figured out how to use FD PFC in S5 T2.

maybe check this out
FD Power FC Installed in S5 FC3s
87GTR is offline   Reply With Quote
Old 05-30-06, 08:32 PM   #20
Total Balance is Key
10 Year Member
 
Turbo II FC's Avatar
 
Trader Score: (13)

Join Date: Jul 2002
Location: ATX
Posts: 1,112
I wish this info was more readily available about 3-4 years ago...lol. I think I would have gone with a Power FC in my FC rather than the Haltech E11 I currently have. I did have a AP Engineering Power FC once a few years back but sold it to NeoFreak. I currently have a Power FC for my FD and love it.
Turbo II FC is offline   Reply With Quote
Old 05-31-06, 11:23 AM   #21
I R SAD PANDA W/O BAW
10 Year Member
 
ilike2eatricers's Avatar
 
Trader Score: (0)

Join Date: Nov 2002
Location: bay area
Posts: 6,061
Quote:
Originally Posted by Turbo II FC
I wish this info was more readily available about 3-4 years ago...lol. I think I would have gone with a Power FC in my FC rather than the Haltech E11 I currently have. I did have a AP Engineering Power FC once a few years back but sold it to NeoFreak. I currently have a Power FC for my FD and love it.
It's mine now muahahaha
ilike2eatricers is offline   Reply With Quote
Old 09-20-07, 09:15 AM   #22
Exhaust Leak
 
Trader Score: (0)

Join Date: Sep 2007
Location: Okinawa, Jp
Posts: 17
Dude you kick ***. I've been trying to figure out where to hook in that damn thing. I'm gonna do it in the morning.
PKaBooo69 is offline   Reply With Quote
Old 09-20-07, 09:15 AM
RX7Club
Mazda RX7




Paid Advertisement


 
 
 
Reply

Tags
ap, apexi, bar, boost, dual, exhaust, fc, fc3s, fd3s, gm, knightsport, map, mazda, rx7, sensor, temprature, water

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On


All times are GMT -5. The time now is 06:45 PM.
All content Copyright © 2007 by Internet Brands, Inc.

Contacts

SEO by vBSEO ©2010, Crawlability, Inc.