89 rx7 n/a trans issues - RX7Club.com

Go Back   RX7Club.com > New Member Section > New Member RX-7 Technical
Log In 

89 rx7 n/a trans issues

LinkBack Thread Tools Search this Thread
Old 04-27-12, 01:35 AM   #1
Junior Member
Trader Score: (0)

Join Date: Feb 2012
Location: Regina
Posts: 10
89 rx7 n/a trans issues

i got a 89 rx7 n/a 5spd the other day it got stuck in reverse tried everything wouldnt come out so today went to put it in the garage and it completly jammed and couldnt roll even with the clutch in so took the trans apart and split the trans, well once it was apart it shifted ok manually.. anyways im just wondering if it could be a bent or bad shift rod or maybe it just slipped outta place and is good to go or what i need to do to fix iit

Zimm is offline   Reply With Quote
Old 04-28-12, 12:02 AM   #2
Senior Member
Trader Score: (6)

Join Date: Mar 2010
Location: B'ham, AL
Posts: 360
Since problem happened in reverse check the 5th/reverse clutch hub and sleeve for good operation as well as the shift fork and rod. Any of these being really worn could cause it to stick reverse. Since it wouldn't move with the clutch in check the shift interlock system. If it is not working properly it could get into two gears, locking the output shaft and preventing it from turning would would not let the wheels move.
CrimsonPride is offline   Reply With Quote
Old 04-28-12, 06:24 AM   #3
Junior Member
Trader Score: (0)

Join Date: Apr 2011
Location: fontana
Posts: 12
.possible throw out bearing? kind of the opposite of your problem.
if its a serious problem, id start with the cheaper things first
i may be really off..im coming from 240s. had several tranny problems and they were always the throwout bearings.
odmoht is offline   Reply With Quote

Similar Threads
Thread Thread Starter Forum Replies Last Post
20b with th400 or th350 trans Sobr609 20B Forum 3 09-26-15 06:40 PM
car show i orillia any interest immanuel__7 Canadian Forum 5 09-02-15 09:26 AM
Gearbox fitment issues. rx7jocke Single Turbo RX-7's 1 08-15-15 04:36 PM
Wiring harness question Professorpeanutrx7 New Member RX-7 Technical 5 08-15-15 02:38 PM
90 GTU RX7: Rebuilt engine, intermittent surge idle in cold/warm climate. ncds_fc New Member RX-7 Technical 1 08-15-15 11:06 AM

89, clutch, interlock, issues, na, reverse, rx7, stuck, tranny, trans

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

All times are GMT -5. The time now is 07:18 AM.

All content Copyright 2007 by Internet Brands, Inc.