RX7Club.com


Go Back   RX7Club.com > Tech and Performance > General Rotary Tech Support
Register Forgot Password?

Welcome to RX7Club.com!
Welcome to RX7Club.com,

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, at no cost, you will have access to start new topics, reply to conversations, privately message other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join RX7Club.com today!


Reply
 
 
 
 
LinkBack Thread Tools Search this Thread Display Modes
Old 10-13-10, 12:13 AM   #1
Cause I Can
 
Trader Score: (3)

Join Date: Mar 2010
Location: Cal State Fullerton
Posts: 127
Spark plugs not firing?

Connected one brand new ngk to the wire to see if I could get it to spark, no spark at all, any help?
Gene! is offline   Reply With Quote
Old 10-13-10, 02:27 AM   #2
Older I get/Faster I go!
10 Year Member
 
Kentetsu's Avatar
 
Trader Score: (0)

Join Date: Jun 2004
Location: Grand Rapids Michigan
Posts: 11,330
Send a message via Yahoo to Kentetsu
What are we, psychics? How about a few details to help us out here?
Kentetsu is offline   Reply With Quote
Old 10-13-10, 09:26 AM   #3
Cause I Can
 
Trader Score: (3)

Join Date: Mar 2010
Location: Cal State Fullerton
Posts: 127
Sorry, I was trying to see if my car wasnt starting because my spark plugs, so I took all four old ones out and checked them, they were alittle gone, so I purchased some new ones , I went home connected one trailing spark plug to the correct wire, next I ground the spark plug to my subframe to see if I could get a spark no spark at all, next I tried a hammer, nothing... I cant figure out why they would fire, could it be my wires? coils? how would I check these?
Gene! is offline   Reply With Quote
Old 10-13-10, 11:02 AM   #4
Mr. Links
10 Year Member
 
Mahjik's Avatar
 
Trader Score: (1)

Join Date: Aug 2001
Location: Kansas City, MO
Posts: 27,520
Send a message via ICQ to Mahjik Send a message via AIM to Mahjik
Did you replace the engine yet? If not, don't bother as you are just wasting time. You already know the compression is bad.
Mahjik is offline   Reply With Quote
Old 10-13-10, 11:18 AM   #5
three spinning triangles
10 Year Member
 
20Bforme's Avatar
 
Trader Score: (0)

Join Date: Oct 2003
Location: SE Wisconsin
Posts: 1,442
Send a message via AIM to 20Bforme Send a message via MSN to 20Bforme Send a message via Yahoo to 20Bforme
Quote:
Originally Posted by Mahjik View Post
Did you replace the engine yet? If not, don't bother as you are just wasting time. You already know the compression is bad.

where did he mention that?
__________________
1986 Rx7 base - sold


RIP Icemark
20Bforme is offline   Reply With Quote
Old 10-13-10, 11:57 AM   #6
Mr. Links
10 Year Member
 
Mahjik's Avatar
 
Trader Score: (1)

Join Date: Aug 2001
Location: Kansas City, MO
Posts: 27,520
Send a message via ICQ to Mahjik Send a message via AIM to Mahjik
Arrow

Quote:
Originally Posted by 20Bforme View Post
where did he mention that?
Engine Help
Mahjik is offline   Reply With Quote
Old 10-13-10, 12:27 PM   #7
three spinning triangles
10 Year Member
 
20Bforme's Avatar
 
Trader Score: (0)

Join Date: Oct 2003
Location: SE Wisconsin
Posts: 1,442
Send a message via AIM to 20Bforme Send a message via MSN to 20Bforme Send a message via Yahoo to 20Bforme
Quote:
Originally Posted by Mahjik View Post
if thats the case, then i agree with what you previously said.
__________________
1986 Rx7 base - sold


RIP Icemark
20Bforme is offline   Reply With Quote
Old 10-13-10, 02:39 PM   #8
Cause I Can
 
Trader Score: (3)

Join Date: Mar 2010
Location: Cal State Fullerton
Posts: 127
Then again I got my compression rechecked 99-90 today front rear after using ams engine cleaner
Gene! is offline   Reply With Quote
Old 10-13-10, 03:11 PM   #9
No Life.
5 Year Member
 
Trader Score: (23)

Join Date: Mar 2009
Location: Clayton NC
Posts: 1,002
if none are firing at all, could br the crank angle sensors,. if they are dead or hooked up wrong,. sparkies wont fire.
Sandrock is offline   Reply With Quote
Old 10-16-10, 05:23 PM   #10
Older I get/Faster I go!
10 Year Member
 
Kentetsu's Avatar
 
Trader Score: (0)

Join Date: Jun 2004
Location: Grand Rapids Michigan
Posts: 11,330
Send a message via Yahoo to Kentetsu
Have to remember that a flooded rotary often shows low or no compression. Probably the number one reason that they end up in the junkyard ahead of their time...
__________________
"Learn from the past, or it will become your future...."

'85 GS 12a/Sterling carb/Respeed coilovers/Respeed front swaybar/Respeed adj. rear spring perches/Illuminas

Kentetsu is offline   Reply With Quote
Old 10-17-10, 07:03 PM   #11
******
5 Year Member
 
flaco's Avatar
 
Trader Score: (6)

Join Date: May 2009
Location: miami
Posts: 864
had to lol
__________________
Injector Flow Testing And Cleaning Services

1580cc Blue Top Bosch Injectors In Stock .

rotarywerks.com
http://www.facebook.com/pages/Rotary...64715410266780
flaco is offline   Reply With Quote
Old 10-18-10, 06:24 PM   #12
Cause I Can
 
Trader Score: (3)

Join Date: Mar 2010
Location: Cal State Fullerton
Posts: 127
How do you deflood?
Gene! is offline   Reply With Quote
Old 10-18-10, 06:24 PM
RX7Club
Mazda RX7




Paid Advertisement


 
 
 
Reply

Tags
brand, car, check, fire, fired, firing, mazda, ngk, park, plug, plugs, reasons, spark, stopped, wires

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -5. The time now is 08:08 PM.
All content Copyright 2007 by Internet Brands, Inc.

Contacts